Message boards : Number crunching : Linux new app version
Message board moderation

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 737
Credit: 140,227,798
RAC: 3
Message 3232 - Posted: 31 Jan 2019, 8:52:55 UTC

New version (0.10) of BHSpin2 application for Linux is released.
Please report any problems with it here.

The version is prepared for new sets of input data. If it will be ok then I release other compilations.
Krzysztof 'krzyszp' Piszczek

Member of Radioactive@Home project team
My Patreon profile
ID: 3232 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Nick Name

Send message
Joined: 22 Feb 15
Posts: 12
Credit: 46,219,855
RAC: 6,229
Message 3235 - Posted: 31 Jan 2019, 17:15:09 UTC - in response to Message 3232.  

100% failure rate here. No problems with version 0.09.

error while loading shared libraries: libmvec.so.1: cannot open shared object file: No such file or directory
ID: 3235 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 737
Credit: 140,227,798
RAC: 3
Message 3236 - Posted: 31 Jan 2019, 17:37:17 UTC - in response to Message 3235.  

Can you tell me some more info about your system, please?

App was compiled on Debian 9.4...

The message suggests that I not include libs as statics...
Krzysztof 'krzyszp' Piszczek

Member of Radioactive@Home project team
My Patreon profile
ID: 3236 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jim1348

Send message
Joined: 28 Feb 15
Posts: 223
Credit: 120,074,881
RAC: 320,829
Message 3237 - Posted: 31 Jan 2019, 17:56:04 UTC - in response to Message 3236.  
Last modified: 31 Jan 2019, 18:43:56 UTC

I don't know when that error occurs, but I have been running 0.10 for 15 minutes under Ubuntu 16.04.5 with no problems.

EDIT: It has finished after 50 minutes and uploaded without error.
https://universeathome.pl/universe/workunit.php?wuid=22990063
ID: 3237 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mmonnin

Send message
Joined: 2 Jun 16
Posts: 150
Credit: 200,043,546
RAC: 47,946
Message 3238 - Posted: 31 Jan 2019, 19:42:02 UTC - in response to Message 3237.  
Last modified: 31 Jan 2019, 20:15:55 UTC

Most are fine for me. One PC has all errors
https://universeathome.pl/universe/results.php?hostid=39977
Ubuntu 14.04, 3570k

Mint 17 and 2x Ubuntu 18.04 systems are ok.
ID: 3238 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Nick Name

Send message
Joined: 22 Feb 15
Posts: 12
Credit: 46,219,855
RAC: 6,229
Message 3239 - Posted: 31 Jan 2019, 22:32:35 UTC

My system is also Ubuntu 14.04. Affected tasks crash immediately after starting.
ID: 3239 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mmonnin

Send message
Joined: 2 Jun 16
Posts: 150
Credit: 200,043,546
RAC: 47,946
Message 3240 - Posted: 31 Jan 2019, 23:19:05 UTC

Correction, the Mint 17 2P 2670v1 system also has the issue. So many aborted that they never reported for me to see until I arrived home.
ID: 3240 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 737
Credit: 140,227,798
RAC: 3
Message 3241 - Posted: 1 Feb 2019, 6:01:59 UTC - in response to Message 3240.  

Ok, I switch off the new version, will compile it again as fully static.
Krzysztof 'krzyszp' Piszczek

Member of Radioactive@Home project team
My Patreon profile
ID: 3241 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
cyrusNGC_224@P3D

Send message
Joined: 21 Feb 15
Posts: 46
Credit: 627,459,817
RAC: 570,963
Message 3242 - Posted: 1 Feb 2019, 9:36:34 UTC

On Debian 8 Jessie it fails, Debian 9 Strech it is ok on my systems.
ID: 3242 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Felipe

Send message
Joined: 1 Feb 19
Posts: 1
Credit: 11,892,726
RAC: 0
Message 3243 - Posted: 1 Feb 2019, 15:01:03 UTC
Last modified: 1 Feb 2019, 15:01:46 UTC

100% failure on kernel 3.13 (Mint 17). 5 machines
100% success on kernel 4.15 (Mint 19). 2 machines
ID: 3243 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 737
Credit: 140,227,798
RAC: 3
Message 3244 - Posted: 2 Feb 2019, 10:55:49 UTC - in response to Message 3243.  

Another version on server.
Should work on kernels 3.2 and above.
Krzysztof 'krzyszp' Piszczek

Member of Radioactive@Home project team
My Patreon profile
ID: 3244 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mmonnin

Send message
Joined: 2 Jun 16
Posts: 150
Credit: 200,043,546
RAC: 47,946
Message 3245 - Posted: 2 Feb 2019, 15:00:53 UTC - in response to Message 3244.  
Last modified: 2 Feb 2019, 15:02:59 UTC

Another version on server.
Should work on kernels 3.2 and above.


It works. For some reason the 0.10 version was much faster. Like 55min to 36min. 0.11 is back to the 0.09 crunch times if not slower.

On a system where 0.10 did not work, v 0.11 is much slower than 0.09. From 70min to 110min.
ID: 3245 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 737
Credit: 140,227,798
RAC: 3
Message 3246 - Posted: 2 Feb 2019, 15:07:15 UTC - in response to Message 3245.  
Last modified: 2 Feb 2019, 15:30:39 UTC

I hope to release Windows, ARM64 and ARM32 compilations today also.

Edit:
There will be no ARM32 application as my Odroid XU4 died :(
(In next few days I will check memory card, maybe this is simple problem to sort).
ID: 3246 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jim1348

Send message
Joined: 28 Feb 15
Posts: 223
Credit: 120,074,881
RAC: 320,829
Message 3248 - Posted: 2 Feb 2019, 17:14:51 UTC - in response to Message 3245.  

It works. For some reason the 0.10 version was much faster. Like 55min to 36min. 0.11 is back to the 0.09 crunch times if not slower.

I see the same thing. On my i7-3770 (Ubuntu 16.04.5), the 0.10 took 50 minutes, while the 0.11 takes 73 minutes.

It would appear to me (though I know nothing about it) that they are linking to older libraries for compatibility purposes. I would always go with the new stuff; as the old rigs are replaced, that is the direction you want to go anyway.
ID: 3248 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Thyme Lawn

Send message
Joined: 15 Oct 17
Posts: 11
Credit: 3,233,144
RAC: 1,753
Message 3249 - Posted: 2 Feb 2019, 21:04:02 UTC - in response to Message 3246.  
Last modified: 2 Feb 2019, 21:04:39 UTC

I hope to release Windows, ARM64 and ARM32 compilations today also.

The version 0.11 app has failed to start 33 tasks on my Windows 10 i7 system (which had had 468 consecutive valid tasks with the version 0.6 app).

BOINC event log messages for universe_bh2_180328_253_6832283168_20000_1-999999_290400_2 were:

02-Feb-2019 16:09:49 [Universe@Home] Process creation failed: (unknown error) - error code 216 (0xd8)
02-Feb-2019 16:09:49 [Universe@Home] Process creation failed: (unknown error) - error code 216 (0xd8)
02-Feb-2019 16:09:50 [Universe@Home] Process creation failed: (unknown error) - error code 216 (0xd8)
02-Feb-2019 16:09:50 [Universe@Home] Process creation failed: (unknown error) - error code 216 (0xd8)
02-Feb-2019 16:09:51 [Universe@Home] Process creation failed: (unknown error) - error code 216 (0xd8)
02-Feb-2019 16:09:51 [Universe@Home] [task] result state=COMPUTE_ERROR for universe_bh2_180328_253_6832283168_20000_1-999999_290400_2 from CS::report_result_error
02-Feb-2019 16:09:51 [Universe@Home] [task] couldn't start app: CreateProcess() failed - (unknown error)
02-Feb-2019 16:09:51 [Universe@Home] [task] task_state=COULDNT_START for universe_bh2_180328_253_6832283168_20000_1-999999_290400_2 from start
02-Feb-2019 16:09:51 [Universe@Home] [task] task_state=COULDNT_START for universe_bh2_180328_253_6832283168_20000_1-999999_290400_2 from resume_or_start1
02-Feb-2019 16:09:51 [Universe@Home] Computation for task universe_bh2_180328_253_6832283168_20000_1-999999_290400_2 finished
02-Feb-2019 16:09:51 [Universe@Home] Output file universe_bh2_180328_253_6832283168_20000_1-999999_290400_2_r662103412_0 for task universe_bh2_180328_253_6832283168_20000_1-999999_290400_2 absent
02-Feb-2019 16:09:51 [Universe@Home] Output file universe_bh2_180328_253_6832283168_20000_1-999999_290400_2_r662103412_1 for task universe_bh2_180328_253_6832283168_20000_1-999999_290400_2 absent
02-Feb-2019 16:09:51 [Universe@Home] Output file universe_bh2_180328_253_6832283168_20000_1-999999_290400_2_r662103412_2 for task universe_bh2_180328_253_6832283168_20000_1-999999_290400_2 absent
02-Feb-2019 16:09:51 [Universe@Home] Output file universe_bh2_180328_253_6832283168_20000_1-999999_290400_2_r662103412_3 for task universe_bh2_180328_253_6832283168_20000_1-999999_290400_2 absent
02-Feb-2019 16:09:51 [Universe@Home] Output file universe_bh2_180328_253_6832283168_20000_1-999999_290400_2_r662103412_4 for task universe_bh2_180328_253_6832283168_20000_1-999999_290400_2 absent
02-Feb-2019 16:09:51 [Universe@Home] Output file universe_bh2_180328_253_6832283168_20000_1-999999_290400_2_r662103412_5 for task universe_bh2_180328_253_6832283168_20000_1-999999_290400_2 absent
02-Feb-2019 16:09:51 [Universe@Home] [task] result state=COMPUTE_ERROR for universe_bh2_180328_253_6832283168_20000_1-999999_290400_2 from CS::app_finished
ID: 3249 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mmonnin

Send message
Joined: 2 Jun 16
Posts: 150
Credit: 200,043,546
RAC: 47,946
Message 3250 - Posted: 2 Feb 2019, 21:51:53 UTC

Looks like windows is already on v0.12
ID: 3250 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jim1348

Send message
Joined: 28 Feb 15
Posts: 223
Credit: 120,074,881
RAC: 320,829
Message 3252 - Posted: 3 Feb 2019, 1:45:23 UTC - in response to Message 3248.  

I see the same thing. On my i7-3770 (Ubuntu 16.04.5), the 0.10 took 50 minutes, while the 0.11 takes 73 minutes.

I now see some 0.11 work units completing in 45 minutes or less. So it was probably just the normal variation in the work unit length that I was seeing, not any significant difference between 0.11 and 0.10 (or 0.09 either).

It would take a much longer average to detect any real differences, if there are any.
ID: 3252 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Beyond
Avatar

Send message
Joined: 19 May 16
Posts: 9
Credit: 212,144,158
RAC: 0
Message 3253 - Posted: 3 Feb 2019, 3:08:12 UTC - in response to Message 3250.  
Last modified: 3 Feb 2019, 3:09:49 UTC

Looks like windows is already on v0.12

The Windows version jumped from v0.06 to v0.11 and then quickly to v0.12. All v0.11 WUs failed immediately but v0.12 seems to be running normally. While it's hard to say for sure because of WU variation, so far it seems that v0.12 is a little slower than v0.06.
ID: 3253 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mmonnin

Send message
Joined: 2 Jun 16
Posts: 150
Credit: 200,043,546
RAC: 47,946
Message 3254 - Posted: 3 Feb 2019, 3:23:32 UTC - in response to Message 3252.  

I see the same thing. On my i7-3770 (Ubuntu 16.04.5), the 0.10 took 50 minutes, while the 0.11 takes 73 minutes.

I now see some 0.11 work units completing in 45 minutes or less. So it was probably just the normal variation in the work unit length that I was seeing, not any significant difference between 0.11 and 0.10 (or 0.09 either).

It would take a much longer average to detect any real differences, if there are any.


One other thing is that on my Zen systems some tasks take 2-3x processing time on 0.09 and 0.11 but I didn't see that on 0.10.

BOINCTask ETA is 50min for 0.11, much slower than the 36min average on 0.10.
ID: 3254 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Nick Name

Send message
Joined: 22 Feb 15
Posts: 12
Credit: 46,219,855
RAC: 6,229
Message 3261 - Posted: 3 Feb 2019, 22:14:52 UTC

0.11 is working fine here as well. There is a mix of WUs, some taking around an hour and some taking 2.5 hours. System is an older 4-core Haswell.
Team USA forum | Team USA page
Always crunching / Always recruiting
ID: 3261 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
1 · 2 · Next

Message boards : Number crunching : Linux new app version




Copyright © 2021 Copernicus Astronomical Centre of the Polish Academy of Sciences
Project server and website managed by Krzysztof 'krzyszp' Piszczek