Message boards : Number crunching : Android 9
Message board moderation

To post messages, you must log in.

1 · 2 · 3 · Next

AuthorMessage
Alessio Susi
Avatar

Send message
Joined: 1 Apr 15
Posts: 49
Credit: 30,557,740
RAC: 0
Message 3141 - Posted: 13 Dec 2018, 0:09:30 UTC

Does Universe@Home work with Android 9 devices? I'm upgrading my OnePlus 5T to Android 9 Pie, but if this is a problem, I'll wait until the WUs will become compatible.
ASUS X570 E-Gaming
AMD Ryzen 9 3950X, 16 core / 32 thread 4.4 GHz
AMD Radeon Sapphire RX 480 4GB Nitro+
Nvidia GTX 1080 Ti Gaming X Trio
4x16 GB Corsair Vengeance RGB 3466 MHz

ID: 3141 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Alessio Susi
Avatar

Send message
Joined: 1 Apr 15
Posts: 49
Credit: 30,557,740
RAC: 0
Message 3153 - Posted: 15 Dec 2018, 8:39:34 UTC

Ok, Universe@Home works with Android 9 ;P
ASUS X570 E-Gaming
AMD Ryzen 9 3950X, 16 core / 32 thread 4.4 GHz
AMD Radeon Sapphire RX 480 4GB Nitro+
Nvidia GTX 1080 Ti Gaming X Trio
4x16 GB Corsair Vengeance RGB 3466 MHz

ID: 3153 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Alessio Susi
Avatar

Send message
Joined: 1 Apr 15
Posts: 49
Credit: 30,557,740
RAC: 0
Message 3159 - Posted: 18 Dec 2018, 18:01:48 UTC

My OnePlus 5T, after upgrading to Android 9, doesn't receive other WUs. What is the problem?
ASUS X570 E-Gaming
AMD Ryzen 9 3950X, 16 core / 32 thread 4.4 GHz
AMD Radeon Sapphire RX 480 4GB Nitro+
Nvidia GTX 1080 Ti Gaming X Trio
4x16 GB Corsair Vengeance RGB 3466 MHz

ID: 3159 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Alessio Susi
Avatar

Send message
Joined: 1 Apr 15
Posts: 49
Credit: 30,557,740
RAC: 0
Message 3230 - Posted: 29 Jan 2019, 21:02:48 UTC

Emmmmh, answers?
ASUS X570 E-Gaming
AMD Ryzen 9 3950X, 16 core / 32 thread 4.4 GHz
AMD Radeon Sapphire RX 480 4GB Nitro+
Nvidia GTX 1080 Ti Gaming X Trio
4x16 GB Corsair Vengeance RGB 3466 MHz

ID: 3230 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Hal Bregg
Avatar

Send message
Joined: 22 Oct 18
Posts: 19
Credit: 3,177,836
RAC: 3
Message 3341 - Posted: 9 Feb 2019, 17:01:27 UTC - in response to Message 3159.  

My OnePlus 5T, after upgrading to Android 9, doesn't receive other WUs. What is the problem?


What U@H has got to do with other projects?
ID: 3341 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
frankhagen

Send message
Joined: 12 Aug 17
Posts: 12
Credit: 52,504,614
RAC: 35,639
Message 3568 - Posted: 21 Jul 2019, 6:20:30 UTC

got a new device which does not receive tasks:
CPU type ARM AArch64 Processor rev 4 (aarch64) [Impl 0x51 Arch 8 Variant 0xa Part 0x801 Rev 4]
Operating System Android 4.4.153-perf+ (Android 9)


any suggestions?
ID: 3568 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 760
Credit: 142,142,465
RAC: 5,737
Message 3592 - Posted: 24 Jul 2019, 20:08:18 UTC - in response to Message 3568.  

Generally? Not... :)

But, tomorrow I plan to compile new Android app, we will see :)
Krzysztof 'krzyszp' Piszczek

Member of Radioactive@Home team
My Patreon profile
Universe@Home on YT
ID: 3592 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
frankhagen

Send message
Joined: 12 Aug 17
Posts: 12
Credit: 52,504,614
RAC: 35,639
Message 3610 - Posted: 29 Jul 2019, 6:30:49 UTC

any news?
ID: 3610 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
JugNut

Send message
Joined: 11 Mar 15
Posts: 37
Credit: 269,824,306
RAC: 11,851
Message 3615 - Posted: 30 Jul 2019, 13:46:20 UTC - in response to Message 3610.  

Yea same, I have 4 android devices waiting for work. Any news?
ID: 3615 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 760
Credit: 142,142,465
RAC: 5,737
Message 3618 - Posted: 30 Jul 2019, 17:59:05 UTC

Android app version added.
Krzysztof 'krzyszp' Piszczek

Member of Radioactive@Home team
My Patreon profile
Universe@Home on YT
ID: 3618 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
sid

Send message
Joined: 13 Apr 17
Posts: 10
Credit: 35,890,333
RAC: 0
Message 3620 - Posted: 30 Jul 2019, 20:06:19 UTC - in response to Message 3618.  

My odroid can't crunch anymore:

Process creation (../../projects/universeathome.pl_universe/BHspin2_19_arm-unknown-linux-gnueabihf) failed: Error -1, errno=2
execv: No such file or directory
uname -a
Linux odroid 4.9.184-37 #1 SMP PREEMPT Wed Jul 10 02:50:15 -03 2019 aarch64 aarch64 aarch64 GNU/Linu

This application was working fine: BHspin2_17_aarch64-unknown-linux-gnu
but not last one - BHspin2_19_arm-unknown-linux-gnueabihf
ID: 3620 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 760
Credit: 142,142,465
RAC: 5,737
Message 3621 - Posted: 30 Jul 2019, 20:22:08 UTC - in response to Message 3620.  

I have some problems with aarch64 linker...
Krzysztof 'krzyszp' Piszczek

Member of Radioactive@Home team
My Patreon profile
Universe@Home on YT
ID: 3621 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
sid

Send message
Joined: 13 Apr 17
Posts: 10
Credit: 35,890,333
RAC: 0
Message 3626 - Posted: 31 Jul 2019, 10:27:50 UTC - in response to Message 3621.  

I have some problems with aarch64 linker...

Is it possible from a server side to enforce the using of old application in this case?
ID: 3626 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 760
Credit: 142,142,465
RAC: 5,737
Message 3628 - Posted: 31 Jul 2019, 12:02:42 UTC - in response to Message 3626.  

No, the old isn't compatible with new data file.
Krzysztof 'krzyszp' Piszczek

Member of Radioactive@Home team
My Patreon profile
Universe@Home on YT
ID: 3628 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
JagDoc
Help desk expert

Send message
Joined: 21 Feb 15
Posts: 80
Credit: 719,284,430
RAC: 43,909
Message 3636 - Posted: 1 Aug 2019, 6:59:43 UTC - in response to Message 3620.  

My odroid can't crunch anymore:

Process creation (../../projects/universeathome.pl_universe/BHspin2_19_arm-unknown-linux-gnueabihf) failed: Error -1, errno=2
execv: No such file or directory
uname -a
Linux odroid 4.9.184-37 #1 SMP PREEMPT Wed Jul 10 02:50:15 -03 2019 aarch64 aarch64 aarch64 GNU/Linu

This application was working fine: BHspin2_17_aarch64-unknown-linux-gnu
but not last one - BHspin2_19_arm-unknown-linux-gnueabihf

My Odroid-C2 and Odroid-N2 run with Universe BHspin v2 v0.19 arm-unknown-linux-gnueabihf without problem.
https://universeathome.pl/universe/show_host_detail.php?hostid=526961

On the Odroid-N2 with this:

sudo dpkg --add-architecture armhf
sudo apt update
sudo apt install libsfstdc++6
sudo apt install libstdc++6:arm64
sudo apt install libstdc++6:armhf

And in the cc_config.xml this:
<options>
<alt_platform>arm-unknown-linux-gnueabihf</alt_platform>
</options>
ID: 3636 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
sid

Send message
Joined: 13 Apr 17
Posts: 10
Credit: 35,890,333
RAC: 0
Message 3648 - Posted: 3 Aug 2019, 15:51:09 UTC - in response to Message 3636.  

My odroid can't crunch anymore:

Process creation (../../projects/universeathome.pl_universe/BHspin2_19_arm-unknown-linux-gnueabihf) failed: Error -1, errno=2
execv: No such file or directory
uname -a
Linux odroid 4.9.184-37 #1 SMP PREEMPT Wed Jul 10 02:50:15 -03 2019 aarch64 aarch64 aarch64 GNU/Linu

This application was working fine: BHspin2_17_aarch64-unknown-linux-gnu
but not last one - BHspin2_19_arm-unknown-linux-gnueabihf

My Odroid-C2 and Odroid-N2 run with Universe BHspin v2 v0.19 arm-unknown-linux-gnueabihf without problem.
https://universeathome.pl/universe/show_host_detail.php?hostid=526961

On the Odroid-N2 with this:

sudo dpkg --add-architecture armhf
sudo apt update
sudo apt install libsfstdc++6
sudo apt install libstdc++6:arm64
sudo apt install libstdc++6:armhf

And in the cc_config.xml this:
<options>
<alt_platform>arm-unknown-linux-gnueabihf</alt_platform>
</options>



Thank you. What exact version of OC are you using?
I have tried on
Linux odroid 4.9.184-37 #1 SMP PREEMPT Wed Jul 10 02:50:15 -03 2019 aarch64 aarch64 aarch64 GNU/Linux

but got:

odroid@odroid:~$ sudo apt install libsfstdc++6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsfstdc++6:armhf : Depends: gcc-8-base:armhf (= 8-20180414-1ubuntu2) but it is not going to be installed
Depends: libsfgcc1:armhf (>= 1:3.5) but it is not going to be installed
Depends: libc6:armhf (>= 2.27) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
ID: 3648 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
JagDoc
Help desk expert

Send message
Joined: 21 Feb 15
Posts: 80
Credit: 719,284,430
RAC: 43,909
Message 3651 - Posted: 4 Aug 2019, 8:18:56 UTC - in response to Message 3648.  

My odroid can't crunch anymore:

Process creation (../../projects/universeathome.pl_universe/BHspin2_19_arm-unknown-linux-gnueabihf) failed: Error -1, errno=2
execv: No such file or directory
uname -a
Linux odroid 4.9.184-37 #1 SMP PREEMPT Wed Jul 10 02:50:15 -03 2019 aarch64 aarch64 aarch64 GNU/Linu

This application was working fine: BHspin2_17_aarch64-unknown-linux-gnu
but not last one - BHspin2_19_arm-unknown-linux-gnueabihf

My Odroid-C2 and Odroid-N2 run with Universe BHspin v2 v0.19 arm-unknown-linux-gnueabihf without problem.
https://universeathome.pl/universe/show_host_detail.php?hostid=526961

On the Odroid-N2 with this:

sudo dpkg --add-architecture armhf
sudo apt update
sudo apt install libsfstdc++6
sudo apt install libstdc++6:arm64
sudo apt install libstdc++6:armhf

And in the cc_config.xml this:
<options>
<alt_platform>arm-unknown-linux-gnueabihf</alt_platform>
</options>



Thank you. What exact version of OC are you using?
I have tried on
Linux odroid 4.9.184-37 #1 SMP PREEMPT Wed Jul 10 02:50:15 -03 2019 aarch64 aarch64 aarch64 GNU/Linux

but got:

odroid@odroid:~$ sudo apt install libsfstdc++6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsfstdc++6:armhf : Depends: gcc-8-base:armhf (= 8-20180414-1ubuntu2) but it is not going to be installed
Depends: libsfgcc1:armhf (>= 1:3.5) but it is not going to be installed
Depends: libc6:armhf (>= 2.27) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have the orginal Hardkernel image Ubuntu 18.04.2 (MATE DESKTOP) for N2.
uname -a show :
Linux n204 4.9.184-37 #1 PREEMT Wed Jul 10 02:50:15 -03 2019 aarch64 aarch64 aarch64 GNU/Linux

You must run all the 5 lines one after the other.

I have this done on all of 9 x Odroid-N2 and it works.
ID: 3651 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
sid

Send message
Joined: 13 Apr 17
Posts: 10
Credit: 35,890,333
RAC: 0
Message 3653 - Posted: 4 Aug 2019, 10:15:28 UTC - in response to Message 3651.  


I have the orginal Hardkernel image Ubuntu 18.04.2 (MATE DESKTOP) for N2.
uname -a show :
Linux n204 4.9.184-37 #1 PREEMT Wed Jul 10 02:50:15 -03 2019 aarch64 aarch64 aarch64 GNU/Linux

You must run all the 5 lines one after the other.

I have this done on all of 9 x Odroid-N2 and it works.


Seems I have the same. Nevertheless:
odroid@odroid:~$ sudo dpkg --add-architecture armhf
odroid@odroid:~$ sudo apt update
Hit:1 http://ports.ubuntu.com/ubuntu-ports bionic InRelease
Hit:2 http://archive.canonical.com/ubuntu bionic InRelease
Hit:3 http://deb.odroid.in/n2 bionic InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
N: Skipping acquire of configured file 'main/binary-armhf/Packages' as repository 'http://deb.odroid.in/n2 bionic InRelease' doesn't support architecture 'armhf'

odroid@odroid:~$ sudo apt install libsfstdc++6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsfstdc++6:armhf : Depends: gcc-8-base:armhf (= 8-20180414-1ubuntu2) but it is not going to be installed
Depends: libsfgcc1:armhf (>= 1:3.5) but it is not going to be installed
Depends: libc6:armhf (>= 2.27) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
odroid@odroid:~$

Probably line in bold is a hint to root cause.
ID: 3653 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
JagDoc
Help desk expert

Send message
Joined: 21 Feb 15
Posts: 80
Credit: 719,284,430
RAC: 43,909
Message 3654 - Posted: 4 Aug 2019, 19:17:01 UTC - in response to Message 3653.  
Last modified: 4 Aug 2019, 19:17:35 UTC

Have you run this lines:
sudo apt install libstdc++6:arm64
sudo apt install libstdc++6:armhf

The last line is for the missing lib.
ID: 3654 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
sid

Send message
Joined: 13 Apr 17
Posts: 10
Credit: 35,890,333
RAC: 0
Message 3655 - Posted: 4 Aug 2019, 21:03:51 UTC - in response to Message 3654.  

Have you run this lines:
sudo apt install libstdc++6:arm64
sudo apt install libstdc++6:armhf

The last line is for the missing lib.


Same error:
odroid@odroid:~$ sudo apt install libstdc++6:arm64
[sudo] password for odroid:
Reading package lists... Done
Building dependency tree
Reading state information... Done
libstdc++6 is already the newest version (8.3.0-6ubuntu1~18.04.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
odroid@odroid:~$ sudo apt install libstdc++6:armhf
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libstdc++6:armhf : Depends: gcc-8-base:armhf (= 8-20180414-1ubuntu2) but it is not going to be installed
Depends: libc6:armhf (>= 2.18) but it is not going to be installed
Depends: libgcc1:armhf (>= 1:3.5) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
odroid@odroid:~$
ID: 3655 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
1 · 2 · 3 · Next

Message boards : Number crunching : Android 9




Copyright © 2022 Copernicus Astronomical Centre of the Polish Academy of Sciences
Project server and website managed by Krzysztof 'krzyszp' Piszczek