Message boards : Number crunching : BHspin v0.05
Message board moderation

To post messages, you must log in.

AuthorMessage
alex

Send message
Joined: 21 Feb 15
Posts: 64
Credit: 53,310,177
RAC: 14,820
Message 838 - Posted: 1 Dec 2015, 21:26:37 UTC

I have a lot of these wu's errored out immediate after start crunching them.
The errorcode is 1 (0x1) Unknown error number
Maybe it's of interest that all they ran on an AMD cpu.
http://universeathome.pl/universe/results.php?hostid=358

Another issue with many Universe wu's is the estimated runtime of 2 seconds. This causes a lot of wu's to be downloaded which is a little bit unfair against other projects.
ID: 838 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jim1348

Send message
Joined: 28 Feb 15
Posts: 236
Credit: 181,811,914
RAC: 226,790
Message 839 - Posted: 2 Dec 2015, 0:13:06 UTC - in response to Message 838.  

Another issue with many Universe wu's is the estimated runtime of 2 seconds. This causes a lot of wu's to be downloaded which is a little bit unfair against other projects.

Let that batch run through and the next ones should have the corrected run times. But then the next group might have some with the short run times, though most will probably be the correct ones. I have not figured out a rhyme or reason for it yet; maybe it will correct itself over time.
ID: 839 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Ananas

Send message
Joined: 26 Mar 15
Posts: 52
Credit: 1,737,270
RAC: 0
Message 840 - Posted: 2 Dec 2015, 0:13:59 UTC - in response to Message 838.  

...
Maybe it's of interest that all they ran on an AMD cpu.
...

Not CPU type related, I had 5 of those on a Xeon.

Some wingmen had a proper stderr message saying that the application could not be found so it might have been a configuration problem on server side. The ones I got later did work.

I already found that my core client - just like yours - doesn't transfer stderr on certain errors. A new "feature" I guess :-(
ID: 840 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
grn

Send message
Joined: 21 Oct 15
Posts: 6
Credit: 2,867,422
RAC: 0
Message 846 - Posted: 3 Dec 2015, 14:39:10 UTC - in response to Message 840.  

I have 3 completed WUs that fail to report. I get the error: "Can't parse file info in scheduler reply; unexpected XML tag or syntax", followed by "No close tag in scheduler reply". Anybody seeing this?
ID: 846 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 748
Credit: 140,959,798
RAC: 9,670
Message 847 - Posted: 3 Dec 2015, 14:57:03 UTC - in response to Message 846.  

I have 3 completed WUs that fail to report. I get the error: "Can't parse file info in scheduler reply; unexpected XML tag or syntax", followed by "No close tag in scheduler reply". Anybody seeing this?

Can you send mi complete file via PM, please?

I know the problem and would like to compare with other...

Probably 863 WU's have this problem - works fine with Linux but cause problems with Windows...
Krzysztof 'krzyszp' Piszczek

Member of Radioactive@Home team
My Patreon profile
Universe@Home on YT
ID: 847 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
grn

Send message
Joined: 21 Oct 15
Posts: 6
Credit: 2,867,422
RAC: 0
Message 849 - Posted: 3 Dec 2015, 15:25:40 UTC - in response to Message 847.  

Not sure which file you mean. Can you give me details?
ID: 849 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 748
Credit: 140,959,798
RAC: 9,670
Message 850 - Posted: 3 Dec 2015, 16:22:13 UTC - in response to Message 849.  

Not sure which file you mean. Can you give me details?

The one which you show part of them...

The problem exists with WU's with "kb" in name, Windows hosts only... As far as I can see...
Krzysztof 'krzyszp' Piszczek

Member of Radioactive@Home team
My Patreon profile
Universe@Home on YT
ID: 850 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile JumpinJohnny
Avatar

Send message
Joined: 1 Dec 15
Posts: 8
Credit: 443,667
RAC: 0
Message 851 - Posted: 3 Dec 2015, 20:10:31 UTC - in response to Message 850.  
Last modified: 3 Dec 2015, 20:50:58 UTC

I joined and completed one WU to test the waters while other CPU projects finished.
Have been trying today to get more WU from Universe@Home but my Boinc Log shows:

12/3/2015 2:46:01 PM | Universe@Home | update requested by user
12/3/2015 2:46:03 PM | Universe@Home | Sending scheduler request: Requested by user.
12/3/2015 2:46:03 PM | Universe@Home | Requesting new tasks for CPU and Miner ASIC and AMD/ATI GPU
12/3/2015 2:46:09 PM | Universe@Home | [error] Can't parse task in scheduler reply: unexpected XML tag or syntax
12/3/2015 2:46:09 PM | Universe@Home | [error] No close tag in scheduler reply

I do NOT have the ASIC miner running or plugged in and Bitcoin Utopia is suspedned with no tasks waiting.
I DO have an AMD 64 cpu and have correct tasks checked for it. Running Windoz 7.

Which is the "unexpected tag/syntax"?? that U@H is seeing?
I will continue to look for sheduler reply unclosed tag but I could use some help here.
I am willing to edit sched_request_universeathome.pl_universe.xml in the C:\ProgramData\BOINC directory if I could see what to do.
Nothing has changed since the first file I downloaded and completed.
Is there a fix I can do from my end? Please be specific.

EDIT 1: PM'd a copy of my sched_request_universeathome.pl_universe.xml

Edit 2:
OK it's wierder than I thought:
The completed task was Universe BHspin v0.03
My Account Tasks on U@H site here are showing a whole bunch of WU
3 - Universe BHspin v0.07
4 - Universe BHspin v0.04
1 - Universe BHspin v0.05
7 - Universe BHspin v0.06
and 5 - Universe ULX v0.03

---NONE of these tasks is showing in my BOINC Manager Tasks or Transfers tabs
---They were all sent 3 seconds starting 3 Dec 2015, 20:10:02 UTC and due Dec 17
I can't get rid of them from this end because they don't exist here.

My U@H prefs are
Use CPU: yes
Run only the selected applications
Universe X-ray sources v4: no
Universe X-ray sources for Android: no
Universe BHspin: yes
Universe ULX: yes
If no work for selected applications is available, accept work from other applications? no
ID: 851 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile JumpinJohnny
Avatar

Send message
Joined: 1 Dec 15
Posts: 8
Credit: 443,667
RAC: 0
Message 852 - Posted: 4 Dec 2015, 1:59:55 UTC - in response to Message 851.  
Last modified: 4 Dec 2015, 2:03:42 UTC

I was able to detach Universe, close boinc mgr and reboot computer and restart boinc then re-add Universe@home to get some WU's.
3 - Universe BHspin 0.05
3 - Universe BHspin 0.07
***Thanks for marking the others as abandoned so I could get more.
ID: 852 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
DigiK-oz

Send message
Joined: 8 Nov 15
Posts: 4
Credit: 1,849,974
RAC: 0
Message 857 - Posted: 4 Dec 2015, 6:54:07 UTC
Last modified: 4 Dec 2015, 7:10:52 UTC

Same issue here :(

12/4/2015 7:40:55 AM | Universe@Home | Requesting new tasks for CPU
12/4/2015 7:40:58 AM | Universe@Home | [error] Can't parse workunit in scheduler reply: unexpected XML tag or syntax
12/4/2015 7:40:58 AM | Universe@Home | [error] No close tag in scheduler reply

Looking at the network traffic with fiddler, I see that the request that is sent to the server is complete, valid XML (about 80 Kbytes) However, the reply that arrives from U@H server is XML, but clearly truncated at 8.168 bytes.

Is it possible that this only happens when a lot of tasks are reported/requested in one scheduler request? I have this on one machine which does not have network connectivity the whole day, so it is usually reporting and requesting a full day worth of WU's. Maybe there is a maximum size for the server reply set somewhere?

If I set "no new tasks", my finished tasks are immediately reported correctly (since the server reply is very small, probably?). After that, I can request work again, but it fails again...and again exactly 8.168 bytes of truncated XML arrives from the U@H server.

Resetting the project does not help. But after removing it and adding it again, I got 1 WU (and the XML reply from U@H server was 7.897 bytes).

It seems that there is a limit in the reply size somewhere. If you have a network connection all day, you will normally only get one new WU per reply, and the reply will be under 8.168 bytes. All will work fine. But once you do request more than one WU, you might run into this...
This *may* fix it (remporarily?)

- Set "no new work" and wait for finished WU's to be reported
- Remove and re-add the project

Can someone please look into this as I am running out of WU's on a regular basis due to this.
ID: 857 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
DigiK-oz

Send message
Joined: 8 Nov 15
Posts: 4
Credit: 1,849,974
RAC: 0
Message 860 - Posted: 4 Dec 2015, 11:57:10 UTC - in response to Message 857.  

Well, still the same issue, but the 8K limit seems to not always be true, I now get some 12K replies from the server, but still truncated XML :(
ID: 860 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 748
Credit: 140,959,798
RAC: 9,670
Message 861 - Posted: 4 Dec 2015, 12:54:45 UTC - in response to Message 860.  

Well, still the same issue, but the 8K limit seems to not always be true, I now get some 12K replies from the server, but still truncated XML :(

Thx for this...
I cant find the problem source. Only what I can see on server side is that problem exists with one batch of WU's and touch only windows based devices...

But information about "cuted" XML's gives me new hope to solve the problem...
Krzysztof 'krzyszp' Piszczek

Member of Radioactive@Home team
My Patreon profile
Universe@Home on YT
ID: 861 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
DigiK-oz

Send message
Joined: 8 Nov 15
Posts: 4
Credit: 1,849,974
RAC: 0
Message 869 - Posted: 5 Dec 2015, 10:53:36 UTC - in response to Message 861.  

Just a tad more info : The replies from the server appear to be encrypted, even though the protocol used is HTTP, not HTTPS

Good luck in finding the issue!
ID: 869 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Krzysztof Piszczek - wspieram ...
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 4 Feb 15
Posts: 748
Credit: 140,959,798
RAC: 9,670
Message 870 - Posted: 5 Dec 2015, 12:48:37 UTC - in response to Message 869.  

Finally I found the source of problem...

For unknown reason at least one batch of WU's (with string "universe_bh_kb....." in name) was faulty generated. One of two template files (results one) was badly saved in database. For mysterious reason server saved only part of the template...

I have canceled those WU and situation should come back to normal...
If you experience the same problem with ULX app just give me a shout as is quite possible that small part of ULX tasks can also have exactly same problem...
Krzysztof 'krzyszp' Piszczek

Member of Radioactive@Home team
My Patreon profile
Universe@Home on YT
ID: 870 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Tex1954

Send message
Joined: 22 Feb 15
Posts: 23
Credit: 36,411,060
RAC: 0
Message 899 - Posted: 12 Dec 2015, 9:35:18 UTC
Last modified: 12 Dec 2015, 9:41:24 UTC

Does this cause the problem where I get XML errors? Seems just now my 2P server setup got locked up...

Win7-DX5680

14964 Universe@Home 12/11/2015 11:51:53 PM [error] Can't parse file info in scheduler reply: unexpected XML tag or syntax
14965 Universe@Home 12/11/2015 11:51:53 PM [error] No close tag in scheduler reply
14966 Universe@Home 12/11/2015 11:59:40 PM Sending scheduler request: To report completed tasks.
14967 Universe@Home 12/11/2015 11:59:40 PM Reporting 47 completed tasks
14968 Universe@Home 12/11/2015 11:59:40 PM Requesting new tasks for CPU and NVIDIA GPU
14969 Universe@Home 12/11/2015 11:59:46 PM [error] Can't parse file info in scheduler reply: unexpected XML tag or syntax
14970 Universe@Home 12/11/2015 11:59:46 PM [error] No close tag in scheduler reply
14971 Universe@Home 12/12/2015 12:10:45 AM Sending scheduler request: To report completed tasks.
14972 Universe@Home 12/12/2015 12:10:45 AM Reporting 47 completed tasks
14973 Universe@Home 12/12/2015 12:10:45 AM Requesting new tasks for CPU and NVIDIA GPU
14974 Universe@Home 12/12/2015 12:10:51 AM [error] Can't parse file info in scheduler reply: unexpected XML tag or syntax
14975 Universe@Home 12/12/2015 12:10:51 AM [error] No close tag in scheduler reply
14976 Universe@Home 12/12/2015 12:36:27 AM Sending scheduler request: To report completed tasks.
14977 Universe@Home 12/12/2015 12:36:27 AM Reporting 47 completed tasks
14978 Universe@Home 12/12/2015 12:36:27 AM Requesting new tasks for CPU and NVIDIA GPU
14979 Universe@Home 12/12/2015 12:36:34 AM [error] Can't parse file info in scheduler reply: unexpected XML tag or syntax

http://universeathome.pl/universe/results.php?hostid=24901&offset=0&show_names=0&state=6&appid=

The only way I was able to correct the problem was to detach and then reattach; a project RESET failed to correct problem. Afterwards, my account showed 29 abandoned WU's that were completed properly on my end so far as I could tell... The next downloads I got 3 Compute Errors immediately too....

8-)
ID: 899 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dr Who Fan
Avatar

Send message
Joined: 20 Feb 15
Posts: 23
Credit: 1,564,459
RAC: 672
Message 947 - Posted: 18 Dec 2015, 2:12:22 UTC

Application version: Universe BHspin v0.05
Task name: universe_bh_kb_5.1_20000_1-999999_191200

Work Unit # 3162762
ALL USERS SO FAR ERROR OUT IMMEDIATELY WITH:

Stderr output
<core_client_version>7.6.9</core_client_version>
<![CDATA[
<message>
Incorrect function.
(0x1) - exit code 1 (0x1)
</message>
<stderr_txt>
15:55:00 (2208): wrapper (7.5.26010): starting
application universe-BHspin missing

</stderr_txt>
]]>


ID: 947 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : BHspin v0.05




Copyright © 2021 Copernicus Astronomical Centre of the Polish Academy of Sciences
Project server and website managed by Krzysztof 'krzyszp' Piszczek